NEWBE - Outbound External Call Issues

Incident Report for LifeSouth IT

Identified

The problem has been identified and a resolution is being worked on. In the meantime a temporary fix has been implemented. Outbound calls are now working.
Posted Feb 13, 2026 - 19:48 EST

Update

We are continuing to investigate this issue.
Posted Feb 13, 2026 - 15:35 EST

Investigating

There is a partial outage with some external outbound calls at NEWBE. We are working with our phone provider to identify and resolve this issue.
Posted Feb 13, 2026 - 15:35 EST
This incident affects: Telephony and NEWBE.