ALL - IBBIS / BEACON Issues

Incident Report for LifeSouth IT

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 18:49 EDT

Monitoring

IBBIS/BEACON seem to have stabilized. If you are still experiencing issues, please contact the Helpdesk at 41685.
Posted Jun 12, 2026 - 15:47 EDT

Investigating

IBBIS/BEACON is currently experiencing issues. IT is aware and working on it.
Posted Jun 12, 2026 - 14:12 EDT
This incident affected: IBBIS, EIS, and CASI.