IBBIS Major Outage

Incident Report for LifeSouth IT

Resolved

BEACON servers appear to have stabilized. If you're still experiencing any issues, please give the helpdesk a call.
Posted Apr 16, 2026 - 16:01 EDT

Investigating

IBBIS is experiencing an unscheduled outage and is currently not available. IT is investigating the issue, and is working to resolve it as soon as possible.
Posted Apr 16, 2026 - 11:05 EDT
This incident affected: IBBIS, EIS, and CASI.