FICO - Secondary Internet Outage

Incident Report for LifeSouth IT

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 14:40 EDT

Identified

A local carrier outage is affecting the secondary internet service at the Jacksonville, FL donor center. This internet service provides backup redundancy for the site, as well as internet access for donor Wi-Fi. Donor Wi-Fi is impacted, but there is no production network impact due to service redundancy.

Current ETR from carrier is 1:20PM.
Posted Apr 21, 2026 - 12:30 EDT
This incident affected: First Coast (FICO).