ALL - IBBIS / BEACON Issues

Incident Report for LifeSouth IT

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 18:12 EDT

Monitoring

The issues seems to be resolved. We will continue to monitor.
Posted Jun 25, 2026 - 15:34 EDT

Investigating

IBBIS/BEACON is currently experiencing some slowness. IT is aware and working on it.
Posted Jun 25, 2026 - 12:04 EDT
This incident affected: IBBIS, EIS, and CASI.