Resolved
PowerDMS has been fully functional for over 24 hours. If you continue to have any issues, please call the help desk at x41685.
Posted Feb 12, 2026 - 08:44 EST
Monitoring
The PowerDMS site has been up for over an hour. Waiting on final work from company that manages this site before closing our Statuspage. Will continue to monitor through the night.
Posted Feb 10, 2026 - 17:56 EST
Investigating
PowerDMS (our documentation library) is down right now. This is an external website and the company that maintains it is aware and looking into it. We will keep everyone notified as we get any updates. If you have further questions, please reach out to the helpdesk at 41685.
Posted Feb 10, 2026 - 16:58 EST
This incident affected: North Florida (CIVI, ALACH, CHIEF, SUWA, PUTN, VALD, DC1, JONES), South Florida (HERN, INVER, CITR, MARI, VIL, SPH, TMP), First Coast (FICO, PAL, FRU, FLE), Georgia (GATL, NEGA, SOCR, LAW, CMI, ALP), North Alabama (NALA, MARS, CULLM, MORG, SHOL, ATH, MAD, ATT, LOG, OWENS), Central Alabama (BIRM, TUSC, ANNIS, TSC, LED, PELHAM), Coastal Alabama (MOBI, BALD, FOL), and EIS, NEWBE.