ALL - IBBIS Outage

Incident Report for LifeSouth IT

Resolved

BEACON servers have stabilized and we believe the issue to be resolved. If you're still experiencing any issues with BEACON, please call the help desk.
Posted Apr 23, 2026 - 15:12 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2026 - 13:32 EDT

Investigating

IBBIS is currently experiencing an outage. IT is aware and working on it.
Posted Apr 23, 2026 - 11:48 EDT
This incident affected: IBBIS, EIS, and CASI.