ALL - IBBIS Outage

Incident Report for LifeSouth IT

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 16:40 EDT

Monitoring

IBBIS appears to have stabilized. If you're still experiencing any issues, please give the helpdesk a call.
Posted Apr 24, 2026 - 15:40 EDT

Investigating

IBBIS is currently experiencing an outage. IT is aware and working on it.
Posted Apr 24, 2026 - 11:28 EDT
This incident affected: IBBIS, EIS, and CASI.